1.17.0 - Kubernetes 1.20, deprecated required/preferred, add sync property to FleetAutoScaler

This is the 1.17.0 release of Agones.

This release brings us support for Kubernetes 1.20, so if you are installing this release, remember to upgrade your clusters.

Starting from this release, required and preferred are deprecated in GameServerAllocation Specification, please use selectors for future allocation match labels.

New functionality highlights in this release include:

  • Added a new property to Fleet Autoscaler for supporting custom sync interval (alpha).
  • Advanced allocation filters, including player capacity and game server state (alpha).

Check the README for details on features, installation and usage.

Breaking changes:

Implemented enhancements:

Security fixes:

See CHANGELOG for more details on changes.

Images available with this release:

Helm chart available with this release:

Make sure to add our stable helm repository using helm repo add agones https://agones.dev/chart/stable

Last modified July 17, 2024: Introduce external resource(s) on multiplayer game programming to docs (#3884) (03a0a4c)